Start a new topic

Unable to login on iPad

Description:When I try to create a new account on my iPad I keep getting;
"We were unable to login to your account at this time. Please try again later."
I've tried numerous times but keep getting the same error. I've tried different passwords also but that doesn't help. Unity is installed on my Mac and appears to be working.
Thank you,

Hi Keith, sorry for the trouble you are encountering. Let me try to sort it out with a few questions:

1) On your iPad, what login method are you using- younity (email/pass), Facebook or Google?

2) On your Mac, what method did you use?

3) Are you trying to create a new account on your iPad or login to your existing account (given that you mention having younity installed on your Mac)?

4) To ask the obvious, is your iPad connected to the Internet?

This will help me track down a few possible issues. Thanks for your patience.
Hi Erik,
Thanks for the quick response. Here are my answers;
1) email/password
2) email/password
3) I've tried both methods. When I enter the same info as I used on my Mac it says, "Please enter a valid email and password". When
I try to create a new account I get the error I gave in my post on
4) Yes, I have an internet connection.

I've also tried deleting the iPad app and reinstalling but have the same problems.

Hi Keith,

If you're sure you remember the e-mail address you used to sign up, have you tried resetting your password? You can do that from the Registration screen in younity. You will be redirected to a web page where you can reset you password to whatever you like.
Exactly where is the registration page you're talking about? There isn't one on and there isn't one on my iPad app. The iPad app only has a "Create" or "Login".


From younity on your Mac or PC, the Registration Dialog will display a 'I forgot my password' link. From younity on iOS, just enter your (failing) e-mail address and password and click Login. If the login fails, younity will display a popup with a 'Forgot' password button. Click that.
I still don't see anything like what you're describing. I did find out how to do it. I went to younity on my Mac and then went to preferences. It had a "Change password" selection there. When I tried to change my password it gave me the following error;

We were unable to change your password.
You supplied an unknown user e-mail address or password. Please retry.
Please contact Entangled Media Support for more information.
Click 'Back' to try again, or 'Cancel' to exit.

I have a password manager I use that keeps user names and passwords so I know I am using the correct email address (user name) and password. In addition, I received an email from Entangled Media stating I registered my computer.


From what you've described, it seems like your Mac is already registered.

Is it your iPad that you cannot register?

If so, are you saying that on your iPad, when you use your e-mail address and password, and then click login, you DO NOT see a popup containing a button saying 'Forgot' my password?
BTW, Change password is different than forgot password. Change password allows a user who knows their password to change it. Forgot password allows a user who has forgotten their password to reset it.
Yes, the problem is on my iPad. That was explained in my original post. And, no, I never see a popup asking if I forgot my password. All I get is the option to login or create an account. See my original post for more detail.
Also, there now seems to be an additional problem. As I stated in my post previous to this one, if I try to change my password on my Mac it tells me I supplied an unknown user email or password. What all this says to me is that after I created an account and received an email from Entanged Media acknowledging the creation of the account younity is telling me I don't have one.
The only clue I can offer is that I created my account with a password that is 20 characters long that included alphanumeric and special characters. Is it possible there is a bug that allowed me to create my account with that password but it will not recognize it when I try to login with it?


I've been following you all along, but let's just start over.

Please just do the following:

1. Grab your iPad.

2. Open younity.

3. You should see 3 buttons:

Login with Facebook

Login with Google

Login with younity

If you do not see those 3 buttons, please just stop right now and tell us what you do see. If you see those 3 buttons, please continue.

4. Click the 'Login with younity' button.

5. Enter your e-mail address and password.

6. Click 'login'

You will get a popup that says "Error. Please enter a valid email and password."

You will see three buttons:

Create new account



7. Click the 'Forgot/Reset' button.

You will see a popup that says "Success. Your password has been reset. Please expect an e-mail at [your e-mail address].

8. Check your e-mail. There will be an e-mail in your Inbox with the subject "younity Password Modification".

9. Please follow the instructions in the e-mail to reset your password. Please of course remember or save the password for future reference.

10. Once your password has been reset, return to your iPad. Click 'Ok' on the popup.

11. Now, enter your new password and click 'login'.

Sorry if this process has been difficult or confusing. We try and improve these processes as we progress. Thanks for your patience.

And of course, let us know how it goes.
Thank you very much, it now works.
My apologies. For some reason, I was so focused on the "Please enter a valid email and password" and the "Create new account" that I just glossed over the "Forgot/Reset" button.
Thanks again for your patience.


You are most welcome. We glad it's working for you now. Please let us know if you have any problems going forward. Thanks for you continued support.
Login or Signup to post a comment