Start a new topic

I can't install Younity on my computer. I have a G5 Power Mac (not intel) Is it not compatible with my computer?

1 Comment


Sorry, we don't support non-Intel Macs. To run younity, you will need to run 10.6 (Snow Leopard) or higher on Mac, or XP SP 3 or higher on Windows.
Login or Signup to post a comment