Start a new topic

OS X 10.5.8 download trouble

I have mac os x 10.5.8 and getting an error when downloading younity. Is my os too old?
1 Comment


Yes, unfortunately, younity only supports OS X 10.6 (Snow Leopard) and later. I hope that the installer indicated as much, but if it did not, please let us know and we will improve the error message. And sorry for the inconvenience. We hope that once you upgrade OS X that you will give us a try.
Login or Signup to post a comment